首页 大数据 poj1503 Integer Inquiry (大数相加)

poj1503 Integer Inquiry (大数相加)

C – Integer Inquiry

Crawling in process…
Crawling failed
Time Limit:1000MS???? Memory Limit:10000KB???? 64bit IO Format:%I64d & %I64u

Submit
Status
Practice
POJ 1503

Appoint description:

Description

One of the first users of BIT’s new supercomputer was Chip Diller. He extended his exploration of powers of 3 to go from 0 to 333 and he explored taking various sums of those numbers.

“This supercomputer is great,” remarked Chip. “I only wish Timothy were here to see these results.” (Chip moved to a new apartment,once one became available on the third floor of the Lemon Sky apartments on Third Street.)

Input

The input will consist of at most 100 lines of text,each of which contains a single VeryLongInteger. Each VeryLongInteger will be 100 or fewer characters in length,and will only contain digits (no VeryLongInteger will be negative).

The final input line will contain a single zero on a line by itself.

Output

Your program should output the sum of the VeryLongIntegers given in the input.

Sample Input

123456789012345678901234567890
123456789012345678901234567890
123456789012345678901234567890
0

Sample Output

370370367037037036703703703670

如果用java做要注意一个细节 就是判断为0的时候不能判断大数的整形值是不是等于0 ?要用一个中间值

import java.math.*;
import java.util.*;
public class Main {
	public static void main(String[] args) {
		Scanner scanner =new Scanner(System.in);
		BigInteger sum=BigInteger.ZERO;
		BigInteger temp2;
		while(scanner.hasNext())
		{
			BigInteger temp=scanner.nextBigInteger();
			temp2=sum;
			sum=sum.add(temp);
			if(temp2==sum){
				System.out.println(sum);
				break;
			}
		}
		scanner.close();
	}
}

关于作者: dawei

【声明】:佛山站长网内容转载自互联网,其相关言论仅代表作者个人观点绝非权威,不代表本站立场。如您发现内容存在版权问题,请提交相关链接至邮箱:bqsm@foxmail.com,我们将及时予以处理。

热门文章